Résolu Paramétrage LDAP

  • cbuisine
  • Portrait de cbuisine Auteur du sujet
Plus d'informations
il y a 2 mois 5 jours #3391 par cbuisine
Paramétrage LDAP a été créé par cbuisine
Bonjour,

J'utilise GRR avec la configuration LDAP depuis plusieurs années. Notre annuaire LDAP est sur un autre serveur, sur le même réseau.
GRR version stable 3.4.0
PHP Version 5.6.30-0+deb8u1

Aujourd'hui, je dois reconfigurer GRR pour qu'il interroge un annuaire Ldap distant. La connexion s'établit correctement mais j'ai un message d'erreur sur lorsque je vais dans la configuration LDAP (voir pièce jointe)

J' arrive pourtant à interroger l'annuaire distant avec la commande ldapsearch et obtient bien les infos ldap de mon uid.

Est-ce que le fait qu'il y ait des caractères spéciaux dans le mot de passe pourrait être en cause ? Y a-til un paquet suplémentaire à installer ou un réglage Apache à effectuer ?

Merci pour votre aide


 
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

  • anteldan
  • Portrait de anteldan
Plus d'informations
il y a 2 mois 4 jours #3392 par anteldan
Réponse de anteldan sur le sujet Paramétrage LDAP
Bonjour,

Ce n'est pas évident.
Il semblerait d'après le message d'erreur que la consultation du LDAP ne soit ouverte aux anonymes. Peut-être qu'il faut utiliser TLS ou des informations d'authentification.

Il se peut aussi qu'il y ait une restriction réseau qui empêche votre serveur GRR d'interroger votre serveur LDAP. Quand vous interrogez l'annuaire distant avec la commande ldapsearch le faites-vous depuis la machine où se trouve GRR ou depuis votre poste de travail ?

Il se peut aussi qu'il faille spécifier l'encodage des caractères utilisés lors de l'interrogation, entre ce qui est émis par votre serveur GRR et ce qu'attend votre serveur LDAP (UTF-8, ISO-8859-1 ?)

Bonnes recherches

Connexion ou Créer un compte pour participer à la conversation.

  • cbuisine
  • Portrait de cbuisine Auteur du sujet
Plus d'informations
il y a 2 mois 4 jours #3393 par cbuisine
Réponse de cbuisine sur le sujet Paramétrage LDAP
C'est bon j'ai trouvé, en fait dans le champ url il fallait tout simplement que je mette ldaps://ur_serveur:port et ça fonctionne.
Merci quand même

Connexion ou Créer un compte pour participer à la conversation.

  • anteldan
  • Portrait de anteldan
Plus d'informations
il y a 2 mois 4 jours - il y a 1 mois 4 semaines #3394 par anteldan
Réponse de anteldan sur le sujet Paramétrage LDAP
J'avais introduit en version 3.4.1 la déclaration explicite du "schema" dans l'URI car j'avais besoin du protocole LDAPS avec une explication au-dessus du champ URI, je n'avais pas en tête que c'était remonté en version 3.4.0.

C'est parfait alors si ça fonctionne :-)
Dernière édition: il y a 1 mois 4 semaines par Yan.

Connexion ou Créer un compte pour participer à la conversation.

Modérateurs: Yan